Backward Compatibility

service_identity has a very strong backward compatibility policy. Generally speaking, you shouldn’t ever be afraid of updating.

If breaking changes are needed do be done, they are:

  1. …announced in the Changelog.

  2. …the old behavior raises a DeprecationWarning for a year.

  3. …are done with another announcement in the Changelog.