Installation and Requirements¶
$ pip install service_identity
Python 2.7, 3.4 and later, as well as PyPy are supported.
Additionally, the following PyPI packages are required:
0.13may work but are not part of CI anymore)
>= 0.6 can be used for internationalized domain names (IDN), i.e. non-ASCII domains.
Unfortunately it’s required because Python’s IDN support in the standard library is outdated even in the latest releases.
If you need Python 3.2 support, you will have to use the latest 0.2.x release. If you need Python 2.6 or 3.3 support, you will have to use the latest 14.0.x release. They will receive bug fix releases if necessary but other than that no further development is planned.